CHUCKIE EGG VEGA

any 1 know wer to get a working version of chuckie egg as the tap version on here doesn't work as u already prob know. cheers

Comments

  • I got it working on my Vega, and I would have got the TAP file from WoS. In what way doesn't it work?

    Maybe you need to use a keymap?

    http://games.zxvega.co.uk/game/chuckie-egg
    My only Speccy game (so far): a simple snake clone
    Thanked by 1Thebeats124
  • Hi . I also got the tap file from wos. The game just stays on the loading screen and does nothing else .
  • Did you press S to start?
    I wanna tell you a story 'bout a woman I know...
  • Hi. I've tried pressing all buttons

  • I downloaded the tap from WoS and it runs perfectly well on an emulator.
    I wanna tell you a story 'bout a woman I know...
  • Sorry I'm quite new to all this. When u say emulator are u not playing it on a vega then ?
  • I've definitely got this working on the Vega. If I remember tomorrow, I'll have a look at this...
    My only Speccy game (so far): a simple snake clone
  • edited July 2016
    I checked, and the version I have is definitely from WoS, and it works fine for me. Have you tried opening up the virtual keyboard and pressing 'S'? That should definitely start the game. If that works and none of the buttons on the Vega itself start the game, that sounds like either an issue with the keymap or the way it's configured.

    If you open the keymap file in a text editor, there should be a line that says 'F:Chuckie Egg.tap'. If for some reason this doesn't match with your TAP file, it would be better to rename the TAP file to match, rather than hand-editing the ZXK keymap file.

    That's the only thing I can think of. If you have the keymap and TAP file in the same directory, it should just work. So on your SD card you should have these 2 files:

    Chuckie Egg.tap
    Chuckie Egg.zxk
    Post edited by chriswyatt on
    My only Speccy game (so far): a simple snake clone
  • Hey chris , many thanks for replying . Thanks for your patience with me coz I am a noob. Turns out it was just me not bringing up the virtual keyboard to get it going and redefine keys
  • Can I use the red keys for up down left right ? Looks like I can only use keys for these actions
  • edited July 2016
    You need to use a keymap:
    http://games.zxvega.co.uk/game/chuckie-egg

    Download it, and stick it in the same directory as 'Chuckie Egg.tap'.

    Some games will 'just work' (Manic Miner being one). Other games you need to select Kempston joystick; however, it's better to create a keymap in this case, so you don't have to mess around with the virtual keyboard each time. Chuckie Egg, unfortunately, does not support Kempston interface, so for this particular game you *must* use a keymap.

    Someone seriously needs to write a how-to for this, as you're not the only one who's struggled with getting certain games to work.

    Redefine keys is probably partially working, because I guess there are some default keys assigned to Fire, Start, 1 and 2. I'm guessing the D-Pad is just assigned to Kempston up/down/left/right, which will be why Chuckie Egg is not picking up those key presses. It's not important anyway, because once you get the keymap in there, you will not have to worry about redefining keys.
    Post edited by chriswyatt on
    My only Speccy game (so far): a simple snake clone
  • just wanna say thanks to u chris. ive just added ur keymap to chuckie egg and it works a treat. ur a credit to
    WOS . many thanks again.
  • Just sorted a working version of c egg , happy but frustrating at the same time
Sign In or Register to comment.