Someone repairing ZX Spectrum in The Netherlands?

Last december I bought a Spectrum 48k of an online marketplace. This week a new powersupply arrived (did not dare to try the old one) and a divMMC device to read games from SD cards.

The Spectrum seems to work fine. The divMMC isn't. When I push the red LED the Spectrum resets. Online I have found two possible reasons:

- bad ram
- a bad z80 with a broken M1 line

For the first problem there is a test, what it passed for. So I am looking into the other problem. But that means buying a new Z80 processor and desoldering/soldering. The first I can do (: The second is not for me. I'm no soldering hero. So I am looking for someone to do that for me. Are there reliable adresses in Europe I can contact? Experience that people have?

Comments

  • Another cause of your problem could simply be dirt or corrosion on the Spectrum's edge connector pins. Try a moisten cotton swab with IPA and work it over the top and bottom of the edge connector pins several times. Might need to use a few cotton swabs if it is very dirty. You don't need to take the Spectrum apart to do this.
  • Which divMMC device did you get? You might just not have your SD card setup properly.
  • Another cause of your problem could simply be dirt or corrosion on the Spectrum's edge connector pins. Try a moisten cotton swab with IPA and work it over the top and bottom of the edge connector pins several times. Might need to use a few cotton swabs if it is very dirty. You don't need to take the Spectrum apart to do this.

    I cleaned the pins with alcohol and the result was the same. The tip of the cotton swab was light grey, so not much corrosion going on there. Pity, cause this was the easiest (:
    RobeeeJay wrote: »
    Which divMMC device did you get? You might just not have your SD card setup properly.

    From the futurewas8bit.com I bought it with a prepared SD card, but also tried an SD card of my own with the package downloaded from their website.

    I appreciate your help!
  • muppets4 wrote: »
    Last december I bought a Spectrum 48k of an online marketplace. This week a new powersupply arrived (did not dare to try the old one) and a divMMC device to read games from SD cards.

    The Spectrum seems to work fine. The divMMC isn't. When I push the red LED the Spectrum resets. Online I have found two possible reasons:

    - bad ram
    - a bad z80 with a broken M1 line

    For the first problem there is a test, what it passed for. So I am looking into the other problem. But that means buying a new Z80 processor and desoldering/soldering. The first I can do (: The second is not for me. I'm no soldering hero. So I am looking for someone to do that for me. Are there reliable adresses in Europe I can contact? Experience that people have?


    Ben Versteeg in Eindhoven, also the guy who made de DivMMC as I recall.
    Bytedelight is the name on twitter/youtube/facebook
  • muppets4 wrote: »
    From the futurewas8bit.com I bought it with a prepared SD card, but also tried an SD card of my own with the package downloaded from their website.

    That's a shame, I got one recently from them and had exactly the same issue (was using the SD card from my DivMMC Enjoy) but using their example zip file fixed it. :/
  • edited January 17
    RobeeeJay wrote: »
    muppets4 wrote: »
    From the futurewas8bit.com I bought it with a prepared SD card, but also tried an SD card of my own with the package downloaded from their website.

    That's a shame, I got one recently from them and had exactly the same issue (was using the SD card from my DivMMC Enjoy) but using their example zip file fixed it. :/

    I was hoping that this would solve it too, cause it’s an easy solution.
    Post edited by muppets4 on
  • muppets4 wrote: »
    [I was hoping that this would solve it too, cause it’s an easy solution.

    Did you solve this? My DivMMC Future isn't working now! I just get a red led when it should be green. I swear this worked before...
  • edited January 28
    RobeeeJay wrote: »
    muppets4 wrote: »
    [I was hoping that this would solve it too, cause it’s an easy solution.

    Did you solve this? My DivMMC Future isn't working now! I just get a red led when it should be green. I swear this worked before...

    Not yet. My Spectrum is for repairs at Ben Versteeg, the guy mentioned above. He will do some other preservation repairs too. I'll keep you informed.

    BTW, my LED never was another colour then red (:


    Post edited by muppets4 on
  • muppets4 wrote: »
    RobeeeJay wrote: »
    Not yet. My Spectrum is for repairs at Ben Versteeg, the guy mentioned above. He will do some other preservation repairs too. I'll keep you informed.

    BTW, my LED never was another colour then red (:

    I just realised that I'd changed SD cards, because I didn't want to waste a larger one in there when I had a smaller 4GB one (and that's plenty big enough!), so I wondered if this might be the cause. I came across another 4GB micro-SD I had spare so I swapped that and mine works now.

    To be sure it was the card (which works fine in my Macbook card slot and PC usb reader) I reformatted it on my Windows 10 machine, and it didn't help. So right now I think it was the card compatibility.

    Good luck with yours, I'm sure when Ben V. sends it back it'll be gleaming! And you may even get to see him repair it on one of his YouTube streams.
  • To all: Thank you!

    Ben did my repairs. Even could see them happen live on Youtube. He is very busy, so it took some time, but my Speccy is like new. And for all the work that he done the price is very reasonable too. So most certainly a reccomendation!
  • edited April 15
    =D>

    Mark
    Post edited by 1024MAK on
Sign In or Register to comment.