+2B: where's the tape signal gone?

So, this is what I really came here for today...

I've got two +2Bs, one with an issue 1 board and some extra soldered wires, and one with an issue 4 board that's free of dodgy-looking fixes - so in the past, I've always opted for the issue 4.

Last time I tried the issue 4, though, the sound coming from the Datacorder had mysteriously vanished. The border colours don't even flicker when Tape Loader is selected, it just sits there in white-bordered silence. Nevertheless, I brought it out of its box again yesterday, found the same problem and figured that last time I must have opened the case, disconnected the lead from the Datacorder to the motherboard and forgotten to put it back. So I opened it again... and the lead was intact.

I can't see any connections that have obviously broken, and the last thing I want to have to do is unleash the soldering iron, which has a pointy tip that only gets hot on the side so it's about as useful for soldering with fine precision as a plumber's blowtorch... and that's before we get onto my twitchy hands and their propensity to fling small objects in random directions with little provocation.

Is there something obvious that I've missed?

Comments

  • Try inserting tape you don't mind recording on, a blank c15 or c90 etc. Then press down record and play together, then press stop. Do this several times, then try loading again. There is a switch on the datacorder's main board that has many pins for making the record and play connections/functions, whichever is selected at the time by the user. Overtime these pins of the record/play switch become oxidized and dirty, which can cause all sorts of odd issues. It's a common problem not just with Spectrums, but any cassette recorder. Working the record and play function a few times gives the switch on the board some exercise and may clear the tarnish off the pins in the switch. If not that check the wires are connected from the rec/play head to board. Also check the screws holding the board to the datacorders mech, these act as grounds, so if loose or poor connection, you'll get some issues there also.
  • So I did something, and sound has been restored from the tape, thus the +2B is now working as it should. But what was it that fixed the problem? What I did was:

    (1) Did exactly what Your Spec-chum suggested - six or seven repetitions of record, stop, record, stop... there was a noticeable clunky-spitting noise from the TV speaker and the border changed colour when I did this, but afterwards, press play only - didn't matter what tape I had in the Datacorder - there was still the square root of sod all coming from the tape head.

    (2) Seven or eight more record-and-stop iterations. Opened the case, prodded around a bit, disconnected the plug for the tape deck and reconnected it, Roy from The IT Crowd style. Still nothing from the tape head.

    (3) Record-and-stop again, times who knows how many. Tried a tape adapter with a different MP3 player to before, this time... with only an audiobook of Brave New World on it. The adapter has quite a chunky cable so I heeded to jab the Datacorder door quite firmly to get it to shut. Press play, prod around some more, there are some more clunky-spitting noises and finally, albeit distorted a fair bit, the sound of Michael York's posh voice telling me about John the Savage...

    ...so I tried the spare (and expendable) Punchy tape I had to hand and that loaded fine. The loading sound was exactly as I expected.

    It's most likely that there's a dodgy connection somewhere deep within the bowels of the tape mechanism, that I'm unlikely to be able to fix permanently, and a bit of Arkwright telling Granville to jer-jer-jiggle it a bit is what I'll have to do if it plays up again.

    Still, the record-and-stop trick is potentially useful and is something I'll bear in mind if any of the other +2s play up this way in the future. Well mown, Your Spec-chum, you've earned yourself a corned beef sandwich.
  • I think the switch will still be your issue. I've seen this fault many times repairing stereo equipment that use the same setup. It's a common issue that plagues them, usually excising the record function brings back the sound, or either strange noises, or even still get nothing at all. It can also affect the record function. In fact the first time I encounted this fault was on an 80's Amstrad tower hifi system. It had record issues where it was recording a loud howling noise through one channel. This stereo had LED VU meters that shown the fault too, as one channel was pegged right to the max on the VU meters. To stop this problem it really needs a good blast or 2 of Servisol switch cleaner into it's rec/play switch as the contacts inside it become dioxide over time. This is on the circuit board that's screwed in placed to the tape mechanism on a both +2 models. It's a long, thin silver/metal part with a white plastic type lever inside it. I've got one to do on a +2 grey I have so if you need photo's, further instructions etc I don't mind helping. Also I have a completely unused +2B(well was before it came to me) that when I first powered it up there was no signal from the tape like yours. Worked the record function and got a loud rumbling sound from the tv. Knew what the fault was straight away. Think I've done 2 or 3 repairs on +2's with this fault.
  • ouch,,, tuck the tape adapter under the door and leave it open.. much kinder on the hinges.. don't forget to press play or the head will be to far away to receive the signal.. as well as above the decks suffer from bad earths and all the solder joints where the wires are attached to the deck board..also i recap them
Sign In or Register to comment.