12V missing on an issue 3

edited July 3 in Hardware
I’ve been working on an issue 3 Spectrum +. It shows thin distorted vertical stripes on bootup. +5 and -5V are all right but the 12V line measures roughly two volts. I’ve already desoldered all the 4116s and changed the TR4 and TR5 to no avail. I know that the other place that uses 12V is the LM1889, which is also not showing a proper voltage. Can a failing LM1889 pull the voltage down? Or should I look into R59?

What should I look into next?

Thanks in advance!
Post edited by protek on

Comments

  • edited July 3
    It’s rare that the LM1889 pulls the +12V rail down.

    And if the -5V supply is in spec, then TR4 & TR5 are very unlikely to be the cause.

    If IC14 (LM1889) is drawing excessive current, there will be a larger than normal voltage across resistor R62 (15Ω).

    With the power off, have you measured the resistance (using the resistance range on your multimeter) between the +12V rail and the 0V/GND rail?

    You can also lift one lead of R62 to isolate the +12A feed to IC14 (LM1889).

    Have you renewed C44 (100uF)?
    Have you renewed D15 (type BA157)?

    Have you seen my blog about the DC-DC modifications?

    Mark


    Post edited by 1024MAK on
  • Looking at your blog right now. I believe some DC-DC mod has been made previously, judging from C47 having been removed and D15 joining legs with another BA157 and an axial capacitor. I haven’t renewed C44 or D15. I’ll have to check if my local shop has the BA157. I do have a few spare axials. I have to check if they match the rating of the C44.

    I’ll check the resistance between the +12V rail and GND and the voltages at the R62 and report back.
  • I measured the resistance between the +12V and GND, resulting 2,7-3,1 kOhms. Voltages at R62 were 1,6V. I didn’t have any 100 uF axials for the C44, so I’ll have to source some. I’ll desolder and test C44 in the meantime.
  • protek wrote: »
    I measured the resistance between the +12V and GND, resulting 2,7-3,1 kOhms. Voltages at R62 were 1,6V. I didn’t have any 100 uF axials for the C44, so I’ll have to source some. I’ll desolder and test C44 in the meantime.

    The fault does not look like a short circuit or overload then (unless a semiconductor is breaking down when subjected to a voltage greater that the test voltage of the multimeter).

    Sinclair went through various different versions of the DC-DC converter circuit. And different versions were used on the various different issues of boards.

    In addition, some boards were modified during manufacturing, or when sent back for service/repair including at some dealers, TV repair shops and service centres. Depending on when the board was modified, and by who, it may or may not have been done to the last known version (as shown on my blog).

    As well as testing/renewing C44, you should also test or renew C45 (same value) and C78/C89 (the extra 22uF). Also test D17 as well as D15. If in any doubt, renew all these components.

    Mark




  • Turned out that the C78/79 that looked slightly dodgy on the outside was also dodgy on the inside. Swapped that and the 12V rail was back. The cap didn’t look burned or bulged, just the outer layer slightly torn on the other end. Like it had been cut with a knife.

    I can now boot into the copyright screen but the keyboard is not responding. I’m also not able to run the Smart Card diagnostic or boot into the Smart Card menu. I tested the lower ram in a known working motherboard and that was okay.
  • edited July 13
    Either the Z80 has crashed due to memory problems (ROM or RAM) or address bus problems, or the Z80 is faulty.

    If it won’t run a diagnostic ‘ROM’, then it’s less likely to be a RAM fault.

    Mark
    Post edited by 1024MAK on
  • I noticed that someone’s worked on the CPU previously and broken a few vias in the process. Those have been fixed with bodge wires.

    I’ll try to check out the broken links and if that doesn’t help, I’ll replace the CPU.
  • I used the logic probe on the CPU. Here’s what I got:
    1 A11 P
    2 A12 P
    3 A13 P
    4 A14 P
    5 A15 P
    6 CLK P
    7 D4 P
    8 D3 P
    9 D5 P
    10 D6 P
    11 +5V H
    12 D2 P
    13 D7 P
    14 D0 P
    15 D1 P
    16 INT P
    17 NMI H
    18 HALT H
    19 MREQ P
    20 IRQ H
    21 RD P
    22 WR H
    23 BUSAK H
    24 WAIT H
    25 BUSRQ H
    26 RESET H
    27 M1 P
    28 REFSH P
    29 GND L
    30-40 A0-A10 P

    H= high, L=low, P=pulse

    Pushing the reset switch pulls reset low, then it goes high again.
  • edited July 16
    I got the CPU and upper ram desoldered and socketed. I also applied better bodge wires on the pins of the CPU that had their traces broken. I tried with a Z80 from my C128 spare board. It seems to boot to Basic like the original Z80A but gives garbage when the Smart card is connected. I also tried a batch of 200 ms 8264 chips on the upper bank with same results.

    I did notice that C27 (1uf 16V) is quite bulged from its sides.
    Post edited by protek on
  • C27 is the capacitor that provides the power on reset, which you have already have said is working in your post on 13th of July and you report in your latest post “seems to boot to BASIC”. So that’s not the cause even if it does not look perfect.

    Have you continuity tested the signals on the edge-connector back to the source? For example, the vast majority go to the Z80. E.g. the sixteen address lines, the eight data lines, all the Z80 control lines. If not, I think it would be good to confirm that all these tracks are intact.

    Also does the /ROMCS line go to the relevant pin on the ROM chip (it goes via the ROM selection links H/N) ? And also to R33 (680 ohms) then to pin 34 of the ULA.

    I also assume you have cleaned and inspected the edge-connector contact pads.

    Mark
  • Well, it was the edge connector contact pads. They didn’t seem grimed at first sight, but when I cleaned them with IPA, the cotton bud turned black. Now the Spectrum boots and I’m able to run diagnostics.

    Thanks, Mark, for all the help!
Sign In or Register to comment.