The SPIN Assembler

edited March 2005 in Emulators
I am using the assembler in Spin but I am having a problem with "DEFS". I was hoping that it would allocate a section of memory but it doesn't seem to be doing it. As there is no documentation I'm not sure if I'm using it correctly. When my code uses DEFB 0,0,0,0,0,0,0,0 it works. When I use DEFS 8 it doesn't. I guess DEFS is not reserving 8 bytes. Can anyone help ? Also, is the editor in the assembler being worked on ? I get a whole host of strange things happening when deleting lines or using the "tab" key.
Post edited by Mr Millside on


  • edited February 2005
    You're using the correct syntax but DEFS is broken in v0.504. Version 0.505 fixes the problem and it will be out soon but you can email us at for a preview copy if you want.

    The editor *is* being worked on but slowly. It's still some way from what I'd like it to be. The TAB bug has gone though, we've fixed some other bugs and we're still looking at others.

  • edited March 2005
    I've been having trouble with the Kilopead game listing here...

    ...which is fine, apart from every occurance of ld a,(ix) or ld (ix),a. It says 'invalid combination of opcode and operands'. The other listing on this page assembles ok, and runs, but then the keys don't seem to work (they should be q,a,o,p,m looking at the listing).

    I've had this opcode/operand thing happen with perfectly good commands (to my tiny bit of m/c knowledge) before. Is it a bug, or is something actually wrong here?
  • edited March 2005
    Instead of using LD (IX),A you should use LD (IX+0),A. You need to add the offset even if the offset is zero.
    I wanna tell you a story 'bout a woman I know...
  • edited March 2005
    Thanks, I'll give it a go.
Sign In or Register to comment.